Menu/Home/Back/Search buttons not working please help - Samsung Galaxy S Forums : Galaxy S2 S II Forum
+ Reply to Thread
Results 1 to 3 of 3

Thread: Menu/Home/Back/Search buttons not working please help

  1. #1
    Junior Member
    Points: 25, Level: 1
    Level completed: 49%, Points required for next Level: 25
    Overall activity: 0%
    Achievements:
    Tagger Second Class
    kristenchia is on a distinguished road
    Join Date
    Jul 2012
    Posts
    1
    Points
    25
    Level
    1

    Menu/Home/Back/Search buttons not working please help

    Hi Everyone,

    New here but would appreciate some help. Have a Galaxy S2 on Sprint network and out of nowhere yesterday the home/menu/back/search buttons stopped working and the phone is running really slow. It came back for like 5 min yesterday afternoon but then started again. I've already done the factory reset and it's still the same way. If I press the call, message, contact buttons on the home screen nothing works. Can someone tell me what to do? Pleeeeeeese. No warranty or insurance. Stupid move i know.

    Thanks,
    Kristen

  2. Remove Advertisements
    Samsung Galaxy S Forum
    Advertisements
     

  3. #2
    Moderator
    Points: 25,427, Level: 69
    Level completed: 76%, Points required for next Level: 173
    Overall activity: 0%
    Achievements:
    Tagger Second Class100 Experience Points7 days registered250 Experience PointsTagger First Class
    Doomed has a brilliant future Doomed has a brilliant future Doomed has a brilliant future Doomed has a brilliant future Doomed has a brilliant future Doomed has a brilliant future Doomed has a brilliant future Doomed has a brilliant future Doomed has a brilliant future Doomed has a brilliant future Doomed has a brilliant future Doomed's Avatar
    Join Date
    Jul 2010
    Location
    Internal Damnation
    Posts
    4,136
    Points
    25,427
    Level
    69
    Quote Originally Posted by kristenchia View Post
    Hi Everyone,

    New here but would appreciate some help. Have a Galaxy S2 on Sprint network and out of nowhere yesterday the home/menu/back/search buttons stopped working and the phone is running really slow. It came back for like 5 min yesterday afternoon but then started again. I've already done the factory reset and it's still the same way. If I press the call, message, contact buttons on the home screen nothing works. Can someone tell me what to do? Pleeeeeeese. No warranty or insurance. Stupid move i know.

    Thanks,
    Kristen
    If you can get into download mode, try flashing a new firmware and see if that helps. (Make sure you get the correct firmware for your phone and provider).
    Arch Linux, with Enlightenment 17
    SGS TripleEye (White) Firmware: Cyanogenmod 10 (JB 4.2.2) - Rooted

  4. #3
    Senior Member
    Points: 10,594, Level: 44
    Level completed: 44%, Points required for next Level: 256
    Overall activity: 15.0%
    Achievements:
    Tagger Second Class7 days registered100 Experience Points31 days registeredTagger First Class
    greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman's Avatar
    Join Date
    Jan 2012
    Posts
    1,865
    Points
    10,594
    Level
    44
    Can you dial *#1234# into your phone to give the details and post them here, so that we can advise on the correct firmware to look for?

    Normally a factory reset will solve the problem, so surprised it hasn't for you.
    Could be a hardware problem, in which case it's a repair.
    Last edited by greenman; 07-26-2012 at 08:06 AM.

  5. Remove Advertisements
    Samsung Galaxy S Forum
    Advertisements
     

+ Reply to Thread

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts