Samsung Galaxy S2 wifi problems - not connecting - Samsung Galaxy S Forums : Galaxy S2 S II Forum
+ Reply to Thread
Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 25

Thread: Samsung Galaxy S2 wifi problems - not connecting

  1. #1
    Junior Member
    Points: 87, Level: 1
    Level completed: 74%, Points required for next Level: 13
    Overall activity: 65.0%
    Achievements:
    Tagger Second ClassTagger First Class
    HokeyPokey is on a distinguished road
    Join Date
    May 2012
    Posts
    12
    Points
    87
    Level
    1

    Samsung Galaxy S2 wifi problems - not connecting

    Hi

    I've just bought my first Samsung Galaxy S2 and love it to bits. The only problem I've encountered in the three days I've had it is that it won't connect via wifi to my home computer (a Mac).

    With my Mac's 'Airport' and 'Internet Sharing' turned on, my boyfriend can connect to wifi from the Mac to his iPhone but my S2 refuses to connect. Once I turn on wifi on the S2, under 'Wi-Fi networks' it brings up my computer and my neighbours' wifi networks. I click on my computer's name, type in the password, but then it just cycles from 'Scanning...', 'Connecting..' to 'Disconnected'.

    I've spent hours trawling Google for a solution. Under the 'Advanced' wifi settings I selected 'Use static IP' (but I'm not convinced I put in the right numbers under 'IP address', 'Gateway', 'Netmask' and 'DNS'). I don't know if it makes a difference but in System Preferences > Network > Airport, it says 'Airport has a self-assigned IP address and may not be able to connect to the Internet'. But my computer is clearly visible on the wifi network because my boyfriend could connect wifi from my computer to his iPhone.

    After disconnecting from wifi, on the S2 I tried dialing *#*#526#*#* and it came up with 'Wlan Test Engineering Mode Status... TestMode Driver loaded [OK]'. But then turning wifi back on and trying to connect to my computer, it still cycles through 'Scanning...', 'Connecting...', 'Disconnected'. So frustrating!

    I haven't tried resetting factory settings because the phone is literally three days new out of the box.

    Appreciate any advice!

    Many thanks,
    Frustrated

  2. Remove Advertisements
    Samsung Galaxy S Forum
    Advertisements
     

  3. #2
    Senior Member
    Points: 10,594, Level: 44
    Level completed: 44%, Points required for next Level: 256
    Overall activity: 15.0%
    Achievements:
    Tagger Second Class7 days registered100 Experience Points31 days registeredTagger First Class
    greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman's Avatar
    Join Date
    Jan 2012
    Posts
    1,865
    Points
    10,594
    Level
    44
    The vagaries of the Mac I have still to understand.
    Mac to mac and you're ok, but there appears to be an inbuilt hatred of other operating systems.

    Try forgetting the wifi network on Samsung Galaxy S2, turn AirPort off the same with your wifi connection on Samsung Galaxy S2. Then turn AirPort and your Samsung Galaxy S2 wifi network on and let it search for the connection again.

  4. #3
    Junior Member
    Points: 87, Level: 1
    Level completed: 74%, Points required for next Level: 13
    Overall activity: 65.0%
    Achievements:
    Tagger Second ClassTagger First Class
    HokeyPokey is on a distinguished road
    Join Date
    May 2012
    Posts
    12
    Points
    87
    Level
    1
    Thanks so much for your quick reply. Yep, I tried the old 'turn it off then on again' on both Airport and the Galaxy S2 wifi but still the same problem. I really love this phone but the wifi problem is so annoying!
    Thanks for your help.

  5. #4
    Senior Member
    Points: 10,594, Level: 44
    Level completed: 44%, Points required for next Level: 256
    Overall activity: 15.0%
    Achievements:
    Tagger Second Class7 days registered100 Experience Points31 days registeredTagger First Class
    greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman's Avatar
    Join Date
    Jan 2012
    Posts
    1,865
    Points
    10,594
    Level
    44
    OK, just to check.
    When you turn off the 'airport' do you pull out mains lead?
    Have a cup of coffee before plugging in and restarting.

    While waiting you could also factory reset your S2 as it's new, or at least, turn off and remove battery.

    Both of these actions should give the wifi link a 'clean' start.

  6. #5
    Senior Member
    Points: 10,594, Level: 44
    Level completed: 44%, Points required for next Level: 256
    Overall activity: 15.0%
    Achievements:
    Tagger Second Class7 days registered100 Experience Points31 days registeredTagger First Class
    greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman's Avatar
    Join Date
    Jan 2012
    Posts
    1,865
    Points
    10,594
    Level
    44
    Found two other 'solutions' if that isn't working:
    1. Download and install WiFi Fixer app to your S2
    https://play.google.com/store/apps/d...ififixer&hl=en

    2. Change the radio mode on your 'airport'
    Switch to a radio mode that does not support 802.11n.
    Open Airport Utility, select your Airport > Wireless. Hold down option while choosing the radio mode. Yes, holding down the option key magically gives you settings you didn't know you had.
    Here you can choose an option that is not 802.11n compatible. I chose 802.11b/g and it worked great.

    http://code.google.com/p/android/iss...il?id=6269#c71

  7. #6
    Senior Member
    Points: 10,594, Level: 44
    Level completed: 44%, Points required for next Level: 256
    Overall activity: 15.0%
    Achievements:
    Tagger Second Class7 days registered100 Experience Points31 days registeredTagger First Class
    greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman's Avatar
    Join Date
    Jan 2012
    Posts
    1,865
    Points
    10,594
    Level
    44
    And yet another 'solution', if you can bare to read through some dodgy language:

    http://www.macworld.com/article/1158...e_station.html

  8. #7
    Junior Member
    Points: 87, Level: 1
    Level completed: 74%, Points required for next Level: 13
    Overall activity: 65.0%
    Achievements:
    Tagger Second ClassTagger First Class
    HokeyPokey is on a distinguished road
    Join Date
    May 2012
    Posts
    12
    Points
    87
    Level
    1
    Thanks heaps greenman for your perseverance. I had a cuppa after turning off Airport, shutting down the computer and S2 and pulling out the mains cord and the S2 battery.

    I ran your 'Solution 1' WiFi Fixer (thanks for the tip) but still the same problem - the constant cycling between 'Scanning', 'Connecting...' and 'Disconnected'. It's like when the ignition of a car just won't turn over - it tries and tries but to no avail.

    Your 'Solution 2': I tried opening up Airport Utility (Applications > Utilities) but got 'You can't open the application "AirPort Utility.app" because it is not supported on this architecture.'

    After wading through the macworld.com link I made sure the password in 'System Preferences > Sharing > AirPort Options' was a five-character password (with the WEP 40-bit key length). The S2 still cycles through trying to connect.

    I'm just going to shut everything down, sleep on it, try again in the morning and then probably scream.

    Thanks heaps again for your help.

  9. #8
    Senior Member
    Points: 10,594, Level: 44
    Level completed: 44%, Points required for next Level: 256
    Overall activity: 15.0%
    Achievements:
    Tagger Second Class7 days registered100 Experience Points31 days registeredTagger First Class
    greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman's Avatar
    Join Date
    Jan 2012
    Posts
    1,865
    Points
    10,594
    Level
    44
    Really sorry not to have found you a solution.
    Who to blame for lack of integration? .... I know who my finger would be pointing at !!!
    Isn't it pathetic that customer's needs are not put before protectionism.

  10. #9
    Junior Member
    Points: 87, Level: 1
    Level completed: 74%, Points required for next Level: 13
    Overall activity: 65.0%
    Achievements:
    Tagger Second ClassTagger First Class
    HokeyPokey is on a distinguished road
    Join Date
    May 2012
    Posts
    12
    Points
    87
    Level
    1
    Hi greenman, success at last (well, sort of). I finally managed to connect to my computer by putting the 'Use static IP' option. I think it was user error before; I put in the wrong info for Gateway and DNS. Now it connects to wifi beautifully. I just don't understand why it's not a seamless process!

    However, with wifi connected, the phone now won't connect to the internet (or any apps). If I was doing cartwheels when it connected to wifi, now I feel I'm back at square one.

    After doing some online reading, some solutions I've unsuccessfully tried:

    Check for firmware updates:
    After turning the phone off, taking out the battery, putting the battery back in and with wifi off (and back on 3G), the phone successfully connects to the internet and apps (such as Facebook and Gmail). The phone's signal strength has two bars. I went to Menu > Settings > About phone > Software update > Update. The message: 'Check for software update? Downloading via 3G network may incur additional charges'. I hit 'OK'. It goes to 'Downloading update package...' with a bar indicating the download progress but it doesn't advance from 0%. Then it comes up with 'Software download is not completed. Continue?'. I hit 'OK' and it jumps back to the 'Software update' page. When I bring up the Notifications bar it says 'Software update Download failed'.

    I downloaded firmware update I9100VJLP7 (May 2012) from samfirmware.com. I downloaded the Kies application but every time I try to open it it quits unexpectedly.

    Something is telling me I'm not supposed to get wifi on my phone.

    The next step is to restore factory settings, although I don't see why this would work because the phone is only five days out of the box. Ho hum.

  11. #10
    Senior Member
    Points: 10,594, Level: 44
    Level completed: 44%, Points required for next Level: 256
    Overall activity: 15.0%
    Achievements:
    Tagger Second Class7 days registered100 Experience Points31 days registeredTagger First Class
    greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman's Avatar
    Join Date
    Jan 2012
    Posts
    1,865
    Points
    10,594
    Level
    44
    I have problems with getting some sites when going online via wifi, yet will connect via mobile data perfectly.
    On these occasions, switching off the router and phone and leaving (for another coffee!!) helps after restart.
    You may also want to clear cache/history in your browser to see if that helps.

    How frustrating for you, and how many times have you wished you bought an iPhone??

    If you manage to overcome the caffeine overdose, hope it works.
    I'll have a search in the meantime.

    PS are you in Brazil?
    Last edited by greenman; 05-07-2012 at 12:40 PM.

  12. Remove Advertisements
    Samsung Galaxy S Forum
    Advertisements
     

+ Reply to Thread
Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts