Wi-fi won't connect - Samsung Galaxy S Forums : Galaxy S2 S II Forum
+ Reply to Thread
Results 1 to 8 of 8

Thread: Wi-fi won't connect

  1. #1
    Senior Member
    Points: 6,249, Level: 33
    Level completed: 72%, Points required for next Level: 101
    Overall activity: 0%
    Achievements:
    Tagger Second ClassTagger First Class7 days registered100 Experience Points250 Experience Points
    Jejoma will become famous soon enough Jejoma will become famous soon enough Jejoma's Avatar
    Join Date
    May 2011
    Location
    EU but not EU
    Posts
    293
    Points
    6,249
    Level
    33

    Wi-fi won't connect

    I was using my wi-fi without any trouble on holiday but now I'm home it will not connect. It sees the wi-fi signal does not seem to connect properly. I've tried re-registering but when it tries to connect the phone goes into a loop giving these messages:

    Authenticating . . . | Save, secured with WPA/WPA2 | Obtaining IP address . . . | Athenticating . . . etc.

    Can anyone help me please?

  2. Remove Advertisements
    Samsung Galaxy S Forum
    Advertisements
     

  3. #2
    Senior Member
    Points: 10,594, Level: 44
    Level completed: 44%, Points required for next Level: 256
    Overall activity: 15.0%
    Achievements:
    Tagger Second Class7 days registered100 Experience Points31 days registeredTagger First Class
    greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman's Avatar
    Join Date
    Jan 2012
    Posts
    1,865
    Points
    10,594
    Level
    44
    Are you sure you have the correct password?
    Is your wifi switched on? If so try switching off and leaving a few minutes before re starting.
    Have you switch wifi back on - if you were in aeroplane mode?

  4. #3
    Senior Member
    Points: 6,249, Level: 33
    Level completed: 72%, Points required for next Level: 101
    Overall activity: 0%
    Achievements:
    Tagger Second ClassTagger First Class7 days registered100 Experience Points250 Experience Points
    Jejoma will become famous soon enough Jejoma will become famous soon enough Jejoma's Avatar
    Join Date
    May 2011
    Location
    EU but not EU
    Posts
    293
    Points
    6,249
    Level
    33
    Hi greenman,

    Are you sure you have the correct password?
    Yes, I tried putting in a false one and the phone reacted differently.

    Is your wifi switched on? If so try switching off and leaving a few minutes before re starting.
    The wi-fi is on and my ipad is connecting without any problem. However, I'll try switching off for half an hour and see if resetting it it helps.

    Have you switch wifi back on - if you were in aeroplane mode?
    Yes, a common mistake but it is switched on and it detects the wi-fi signal.

  5. #4
    Senior Member
    Points: 10,594, Level: 44
    Level completed: 44%, Points required for next Level: 256
    Overall activity: 15.0%
    Achievements:
    Tagger Second Class7 days registered100 Experience Points31 days registeredTagger First Class
    greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman has a brilliant future greenman's Avatar
    Join Date
    Jan 2012
    Posts
    1,865
    Points
    10,594
    Level
    44
    If still having problems try clearing out your old wifi saved connections so you only have your home one.
    Disconnect your ipad and connect S2 first.

    If still not working there's some ideas here:
    http://androidforums.com/samsung-gal...home-wifi.html

  6. The Following User Says Thank You to greenman For This Useful Post:

    Jejoma (04-15-2012)

  7. #5
    Super Moderator
    Points: 58,622, Level: 100
    Level completed: 0%, Points required for next Level: 0
    Overall activity: 99.8%
    Achievements:
    Tagger Second Class7 days registered100 Experience PointsTagger First Class31 days registered
    RichH has a reputation beyond repute RichH has a reputation beyond repute RichH has a reputation beyond repute RichH has a reputation beyond repute RichH has a reputation beyond repute RichH has a reputation beyond repute RichH has a reputation beyond repute RichH has a reputation beyond repute RichH has a reputation beyond repute RichH has a reputation beyond repute RichH has a reputation beyond repute RichH's Avatar
    Join Date
    Dec 2011
    Location
    Coventry
    Posts
    3,603
    Points
    58,622
    Level
    100
    This is an indication that the phone was unable to obtain an IP address. Try selecting a static IP address, temporarily at least, to see if it will connect.

  8. #6
    Senior Member
    Points: 6,249, Level: 33
    Level completed: 72%, Points required for next Level: 101
    Overall activity: 0%
    Achievements:
    Tagger Second ClassTagger First Class7 days registered100 Experience Points250 Experience Points
    Jejoma will become famous soon enough Jejoma will become famous soon enough Jejoma's Avatar
    Join Date
    May 2011
    Location
    EU but not EU
    Posts
    293
    Points
    6,249
    Level
    33
    Thank you for all the suggestions. In the end I cleared both caches on the phone, re-ran the setup wizard and switched the phone and the modem off all night. Something worked, unfortunately I don't know what. Still, at least I didn't have to reflash the ROM which was going to be my next step.

  9. #7
    Junior Member
    Points: 15, Level: 1
    Level completed: 29%, Points required for next Level: 35
    Overall activity: 0%
    Achievements:
    Tagger Second Class
    Krakhis is on a distinguished road
    Join Date
    Jun 2012
    Posts
    1
    Points
    15
    Level
    1
    I think I may have found the problem that you were having.
    At home I have no problem connecting to my network, but tonight, I was having trouble connecting to the network,
    it remember the location, tried connecting, connected, tried obtaining IP, and then disabled.
    I opened up the router settings and I found with the dchp that it only allows a max of 10 devices to be connected
    I switched it to 20 like it shows in the picture and shortly after that my phone connected.
    Attachment 1367

    That would explain why restarting the router allows your phone to connect, since it closed all the connections to any devices.

    Hope this helps anyone else.

  10. #8
    Senior Member
    Points: 6,249, Level: 33
    Level completed: 72%, Points required for next Level: 101
    Overall activity: 0%
    Achievements:
    Tagger Second ClassTagger First Class7 days registered100 Experience Points250 Experience Points
    Jejoma will become famous soon enough Jejoma will become famous soon enough Jejoma's Avatar
    Join Date
    May 2011
    Location
    EU but not EU
    Posts
    293
    Points
    6,249
    Level
    33
    Hi Krakhis,
    That sounds like a very likely cause / solution for my problem. I'll have to remember it for next time. Many thanks.

  11. Remove Advertisements
    Samsung Galaxy S Forum
    Advertisements
     

+ Reply to Thread

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts