Hey all,

It looks like this issue is old but maybe this will help. I am running Jelly Bean 4.2 on my SG SII and my provider is sprint.

For me this fixed the issue: settings -- > more settings --> mobile networks --> sprint connection optimizer: uncheck

This service will auto switch wifi on when saved networks are in range to "save" mobile data. The happens regardless of if you turn wifi off.

Hopefully this helps you in some way!

regards,