[SGS] Can't disable USB storage mode - Samsung Galaxy S Forums : Galaxy S2 S II Forum
+ Reply to Thread
Results 1 to 8 of 8

Thread: Can't disable USB storage mode

  1. #1
    Junior Member
    Points: 31, Level: 1
    Level completed: 62%, Points required for next Level: 19
    Overall activity: 3.0%
    Achievements:
    Tagger Second Class
    poddy is on a distinguished road
    Join Date
    Nov 2011
    Posts
    2
    Points
    31
    Level
    1

    Can't disable USB storage mode

    Hi-having major problems, which I think are all related to not being able to turn off the USB storage mode.

    Phone not recognising SD card or internal memory but can use phone to call and text etc.

    When I go to use Camera it says to turn off USB storage mode. Setting is for Mass storage and when I connect cable to PC I get an android Icon with a 'Turn off' button for USB storage but when I click it it just hangs.

    I think it is this problem causing the phone not to recognise the SD card and internal SD but I can't figure out how to disable it.

    Have tried Factory reset but get the message E:can't mount/dev/block/mmcblk0p1 (invalid argument) and if I try to format the SD card I get a similar message.

    Can anyone please help?

    Thanks

    Poddy

  2. Remove Advertisements
    Samsung Galaxy S Forum
    Advertisements
     

  3. #2
    Stupid Modulator
    Points: 15,075, Level: 53
    Level completed: 32%, Points required for next Level: 375
    Overall activity: 68.0%
    Achievements:
    7 days registered31 days registeredTagger Second Class100 Experience PointsTagger First Class
    stonkr has much to be proud of stonkr has much to be proud of stonkr has much to be proud of stonkr has much to be proud of stonkr has much to be proud of stonkr has much to be proud of stonkr has much to be proud of stonkr has much to be proud of stonkr has much to be proud of stonkr's Avatar
    Join Date
    Jan 2011
    Location
    Note 4 Waiting Room
    Posts
    2,149
    Points
    15,075
    Level
    53
    First thoughts are that your external SD card is at fault.

    Try taking it out and see if your phone works normally.

    If it does, use a card reader and your PC to take all your data off the card and reformat it, then put the data back on and reinsert it in your phone.

    Welcome to the forum
    I could be wrong, I usually am. (Because it's only a phone)
    Triple Eye Pebble with extra added E=MC²:CF-Root:JKay Deluxe
    What next: Note 4?

  4. #3
    Junior Member
    Points: 31, Level: 1
    Level completed: 62%, Points required for next Level: 19
    Overall activity: 3.0%
    Achievements:
    Tagger Second Class
    poddy is on a distinguished road
    Join Date
    Nov 2011
    Posts
    2
    Points
    31
    Level
    1
    Thanks stonkr, have already tried that. In terms of the Internal SD card it says that is either blank or unsupported. I read somewhere (can't find it again on Google) that if you haven't disabled the USB storage then the phone won't recognise either its internal or external memory. And as my USB storage seems to be on all the time (it comes up with a message when you try to use the camera to shut down USB storage) I'm assuming that's the problem. I've tried all the obvious things but just can't seem to turn it off.

  5. #4
    Stupid Modulator
    Points: 15,075, Level: 53
    Level completed: 32%, Points required for next Level: 375
    Overall activity: 68.0%
    Achievements:
    7 days registered31 days registeredTagger Second Class100 Experience PointsTagger First Class
    stonkr has much to be proud of stonkr has much to be proud of stonkr has much to be proud of stonkr has much to be proud of stonkr has much to be proud of stonkr has much to be proud of stonkr has much to be proud of stonkr has much to be proud of stonkr has much to be proud of stonkr's Avatar
    Join Date
    Jan 2011
    Location
    Note 4 Waiting Room
    Posts
    2,149
    Points
    15,075
    Level
    53
    Do you mean settings > wireless and network > USB settings > mass storage? Mine is set to that all the time without problems.

    Or is it settings > applications > development > USB debugging? That also doesn't cause me any problems.

    Have you recently updated your firmware? Could be a partition problem.
    I could be wrong, I usually am. (Because it's only a phone)
    Triple Eye Pebble with extra added E=MC²:CF-Root:JKay Deluxe
    What next: Note 4?

  6. #5
    Senior Member
    Points: 32,565, Level: 79
    Level completed: 15%, Points required for next Level: 685
    Overall activity: 20.0%
    Achievements:
    Tagger Second Class100 Experience Points7 days registeredTagger First Class250 Experience Points
    Goots has a reputation beyond repute Goots has a reputation beyond repute Goots has a reputation beyond repute Goots has a reputation beyond repute Goots has a reputation beyond repute Goots has a reputation beyond repute Goots has a reputation beyond repute Goots has a reputation beyond repute Goots has a reputation beyond repute Goots has a reputation beyond repute Goots has a reputation beyond repute Goots's Avatar
    Join Date
    Aug 2010
    Location
    North Wales, UK
    Posts
    2,959
    Points
    32,565
    Level
    79
    Same as Stonkr here, I have USB set to mass storage, and USB debugging activated permanently and can't remember the time when I didn't.
    Google Nexus 4 Android v4.3 Twitter : @1969guy Circle me on Google+

  7. #6
    Junior Member
    Points: 12, Level: 1
    Level completed: 23%, Points required for next Level: 38
    Overall activity: 0%
    mh09ad5578 is on a distinguished road
    Join Date
    Jun 2012
    Posts
    1
    Points
    12
    Level
    1
    ok guys same problem with my Galaxy note i717. i have rooted it and can acess the sd card in recovery but not the other times and as poddy said the turn usb storage off message keeps flashing all the time. also in recovery i get the message-E:can't mount/emmc.
    please help its driving me nuts!!!!!!!!!!!

  8. #7
    Super Moderator
    Points: 57,331, Level: 100
    Level completed: 0%, Points required for next Level: 0
    Overall activity: 54.0%
    Achievements:
    Tagger Second Class7 days registered100 Experience PointsTagger First Class31 days registered
    RichH has a reputation beyond repute RichH has a reputation beyond repute RichH has a reputation beyond repute RichH has a reputation beyond repute RichH has a reputation beyond repute RichH has a reputation beyond repute RichH has a reputation beyond repute RichH has a reputation beyond repute RichH has a reputation beyond repute RichH has a reputation beyond repute RichH has a reputation beyond repute RichH's Avatar
    Join Date
    Dec 2011
    Location
    Coventry
    Posts
    3,574
    Points
    57,331
    Level
    100
    The problem is that your SD card (S) are not mounted by the system. Go to recovery and choose "mount emmc" and /or mount SD card options. You may have to do this in CWM recovery.
    Samsung ATIVs SIM Free. Orange UK. WP8
    SGS 3 i9305 SIM Free. Dev Tool. Galaxy Project ROM. 4.3. Three UK
    HTC ONE Gold O2 UK 4G
    "Help4Mobiles"

  9. #8
    Junior Member
    Points: 12, Level: 1
    Level completed: 23%, Points required for next Level: 38
    Overall activity: 0%
    natemobley is on a distinguished road
    Join Date
    May 2013
    Posts
    1
    Points
    12
    Level
    1
    I know this is an old thread but if you upgraded to Jellybean you will need to turn of USB mass storage at Settings>More Settings>USB Utilities

  10. Remove Advertisements
    Samsung Galaxy S Forum
    Advertisements
     

+ Reply to Thread

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts