Why does my WIFI keeping disconnecting? - Samsung Galaxy S Forums : Galaxy S2 S II Forum
+ Reply to Thread
Results 1 to 6 of 6

Thread: Why does my WIFI keeping disconnecting?

  1. #1
    Junior Member
    Points: 59, Level: 1
    Level completed: 18%, Points required for next Level: 41
    Overall activity: 7.0%
    Achievements:
    7 days registeredTagger Second Class
    207 is on a distinguished road
    Join Date
    Oct 2011
    Posts
    2
    Points
    59
    Level
    1

    Why does my WIFI keeping disconnecting?

    Ill enable wi-fi, go back to it 3-4 mins later and it is greyed out (disconnected). I have to keep enabling it and this is getting annoying. Anyone have a fix or resolution for this?
    Thanks

  2. Remove Advertisements
    Samsung Galaxy S Forum
    Advertisements
     

  3. #2
    Senior Member
    Points: 3,872, Level: 26
    Level completed: 24%, Points required for next Level: 228
    Overall activity: 0%
    Achievements:
    Tagger Second Class7 days registered100 Experience PointsTagger First Class250 Experience Points
    Professor Yaffle has a spectacular aura about Professor Yaffle has a spectacular aura about Professor Yaffle has a spectacular aura about
    Join Date
    Mar 2011
    Posts
    363
    Points
    3,872
    Level
    26
    Quote Originally Posted by 207 View Post
    Ill enable wi-fi, go back to it 3-4 mins later and it is greyed out (disconnected). I have to keep enabling it and this is getting annoying. Anyone have a fix or resolution for this?
    Thanks
    A few things to check:

    1. Which type of encryption does your router use? WPA2 seems to the most stable.
    2. What DHCP lease time does your router have? If 0 (Forever) later firmwares have an issue with this.
    3. What's your Sleep Policy (Settings, Wireless and Network, Wi-Fi Settings, [Menu], Advanced, Wi-Fi Sleep Policy). Is it set to Never? (which may help).
    4. Are you using the latest firmware for your phone?

    Obviously, other issues such as signal strength and stability may come into play too. Use an App such as Wi-Fi Manager to see which channels competing networks use. If another channel from 1, 6 or 11 is less used than your current channel, consider changing it on your router.

  4. #3
    Junior Member
    Points: 59, Level: 1
    Level completed: 18%, Points required for next Level: 41
    Overall activity: 7.0%
    Achievements:
    7 days registeredTagger Second Class
    207 is on a distinguished road
    Join Date
    Oct 2011
    Posts
    2
    Points
    59
    Level
    1
    1. I dont know but it happens too going down the road where wi-fi is not needed
    2. not sure
    3. it is set to never
    4. i just went into settings and it says no updates available

  5. #4
    Senior Member
    Points: 3,872, Level: 26
    Level completed: 24%, Points required for next Level: 228
    Overall activity: 0%
    Achievements:
    Tagger Second Class7 days registered100 Experience PointsTagger First Class250 Experience Points
    Professor Yaffle has a spectacular aura about Professor Yaffle has a spectacular aura about Professor Yaffle has a spectacular aura about
    Join Date
    Mar 2011
    Posts
    363
    Points
    3,872
    Level
    26
    Quote Originally Posted by 207 View Post
    1. I dont know but it happens too going down the road where wi-fi is not needed
    2. not sure
    3. it is set to never
    4. i just went into settings and it says no updates available
    1. Get an app such as Y5 - that'll hopefully enable/disable Wi-Fi automatically as you go out of or into range of a recognised network (saves battery)
    2. Especially if your router is a Belkin, do some Googling for your model on how to check the DHCP lease time
    3. OK
    4. Have you tried looking for an update via the Samsung Kies PC software? If you post your current firmware version (Settings, About Phone), someone else here may be able to determine whether an update is available (assuming you're not going to flash it manually).

  6. #5
    Junior Member
    Points: 466, Level: 7
    Level completed: 66%, Points required for next Level: 34
    Overall activity: 0%
    Achievements:
    7 days registered31 days registered100 Experience Points3 months registeredTagger Second Class
    rehmondo is on a distinguished road
    Join Date
    Apr 2011
    Posts
    5
    Points
    466
    Level
    7
    Other than the suggestion provided if you cannot access your routers admin section (if at work etc), then what you need to do is go to wi-fi using the option key and the advanced icon appears - select this and give yourself a static ip - you may need some help from the administrator for the correct settings - this cures it in all scenarios however when you go to an area where you didn't have any wi-fi issues please remember to untick static ip.

    Gingerbread isn't that good when it comes to this as you can only ever assign one static ip to the phone and not one per wi-fi connection like you can in honeycomb - can be a complete pain in the arse if your needing a static ip in more than one place.

    PS don't be alarmed most newer handsets suffer from this problem its not just a samsung/android thing by any means.

  7. #6
    Junior Member
    Points: 35, Level: 1
    Level completed: 70%, Points required for next Level: 15
    Overall activity: 25.0%
    jackinthebox is on a distinguished road
    Join Date
    Nov 2011
    Posts
    11
    Points
    35
    Level
    1
    Hey
    Im new to this. Im also having trouble with my internet. Not only Wi Fi but all my internet. It has been slow and also when I go to open some apps it tells me there is a connection error. Is there anything I can do to fix this?
    Thanks

  8. Remove Advertisements
    Samsung Galaxy S Forum
    Advertisements
     

+ Reply to Thread

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts